Adding Shader Effect File crashes VS2010

Dec 30, 2010 at 9:03 PM

Hello,

I am very keen to use your VS2010 plugin to create my own Shader Effects, but I have no luck with Version 1.7.1. Every time I create a new project and add the Shader Effect File Template, VS 2010 crashes. I tried it on a 64bit machine and now also on 32bit and it is always the same! Any idea what I could try to get it running?

 

regards

Joachim

Coordinator
Dec 30, 2010 at 10:25 PM

Hmm...the 1.7.1 version is suppose to be able to function without the latest DirectX runtime installed.  But perhaps I missed something.  Download the DirectX runtime updater from Microsoft here, http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en .  That's the only thing I could imagine would cause it to crash, because as soon as you add the templated item, it's going to attempt to compile it.  So if for whatever reason the dlls I packaged with the 1.7.1 version are not enough that would cause it to crash for sure.

Jan 12, 2011 at 10:30 PM

Just an FYI on this - I was getting the same error as Joachim with the 1.7.1 install (VS2010, Win7, 64bit).  I downloaded the DirectX runtime updater you pointed to here, ran it, then reopened my project and tried it and it worked fine. Since Joachim didn't respond to you, I thought you might be interested in knowing that your solution did work. Hopefully that leads you to being able to fix it in a future release so we can skip that step.

Coordinator
Jan 12, 2011 at 11:35 PM

Good to know, thanks.  I'll try and figure out what I'm missing for the next version.